Showing results for 
Search instead for 
Did you mean: 
New Member

Setting default MTU size for hamachi network

Hi all, I've some problems connecting a client to remote SQL Server 2008R2 over an Hamachi network cause TCP connection suddenly drops on certain SQL operation involving BLOB data.


After some different trials I found out that the issue is somehow related with the default Hamachi MTU size of 1404. Setting it to 1000 with netsh utility solved my problem.


Every time Hamachi restarts the MTU size is set again to 1404 breaking the connection again so I had to give users a script they need to manually launch after reboot or connection reset.


I was wondering if there's an option in hamachi configuration file that gives the user the ability to change the default MTU size to a different value.

Looking at the different configuration files I found on my system in Hamachi related folders I did not find any setting that seems to help me but I noticed in the logs that in the boot process MTU size is deliberately set with a netsh command call expecially in the h2-engine.log:


02/09 19:40:42.068 [33516] tap: init(), devName [Hamachi]
02/09 19:40:42.069 [33516] tap: list_netdev_win32() ..
02/09 19:40:42.493 [33516] tap: set mtu
02/09 19:40:42.884 [33516] sys: run_command(netsh interface ipv4 set subinterface "Hamachi" mtu=1404 store=persistent), done with 0


Hope someone can help me solve that!





GoTo Manager

Re: Setting default MTU size for hamachi network

Hi @techsrl, welcome to the community.


We are looking into a possible solution, would you be able to provide us with a list of the MTU values of the physical interfaces?


Glenn is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!.
Do you want a new feature added? Make sure you Kudo (vote) for the Idea

Free user and admin training
New Member

Re: Setting default MTU size for hamachi network

We have the same issues with file transfer by SMB over hamachi. I some cases (depeding on the kind of internet connection) it is not possible to up- or download files (even small ones). With changing MTU size by netsh to 1.000 everything runs fine. We solved this with a powershell script running every 5 minutes...