cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

New Client no longer works for iMac 10.12.6

LMI released a new client on 12-10-2020 that does not work with any Mac with OS 10.12 or older.  LMI support has no resolution for this.  You cannot download an older client as well.  This is just crazy.  I have an estimated 20 plus computers that cannot remote in anymore to their office computers.    

Tags (3)
3 REPLIES 3
LogMeIn Contributor

Re: New Client no longer works for iMac 10.12.6

@Tremont_Tech  We are fully compatible with the newest Mac releases.  What versions are you running where you see compatibility problems?

What "doesn't work" exactly on the Host side?

New Contributor

Re: New Client no longer works for iMac 10.12.6

The LMI client will not launch or install with iMac OS version 10.12.6 or later.  You must have 10.13 or better.   Unfortunately,  this particular Mac cannot be upgraded to 10.13.  So the LMI will not work.  Hope that explains it.  

LogMeIn Contributor

Re: New Client no longer works for iMac 10.12.6

OK, thanks for confirming.  I apologize that we had to move on from older Mac OS due to Apple stopping support for them as well.  Unfortunately we don't offer older install versions for download.