cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor

Cannot get adapter config on diagnose

Tunnel: OK

Local results:
	Adapter configuration: OK
	Traffic test: OK
Peer results: [217-079-555]
	Adapter configuration: 
			Cannot get adapter config
	Traffic test: Cannot complete test

this is what i get when i hit "diagnose" on my friend's icon...also i get the "relayed tunnel" issue?any help?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Active Contributor

Re: Cannot get adapter config on diagnose

Hi. I fixed that problem by unchecking items on the Hamachi Network Interface. I unchecked two items: Microsoft PEF NDIS ETW Provider Driver and Microsoft Network Monitor 3, then I restarted the VPN and got it working! Might not be the same items, try to disable many and see if it works, because disabling only one of those two, didn't work. I had to disable a few. Let only enabled Client for Microsoft networks, File and Printers share for Microsoft networks, the IP version 4 and version 6, E/S controller and the (really not well translated) device of answer of detection...... (at least with Windows 7). Let only those 6 and enable one by one to see which ones are causing the issue. Sorry for the items list, I couldn't translate them very well, specially the last one. Hope this helps!

View solution in original post

7 REPLIES 7
Highlighted
Active Contributor

Re: Cannot get adapter config on diagnose

Hi. I fixed that problem by unchecking items on the Hamachi Network Interface. I unchecked two items: Microsoft PEF NDIS ETW Provider Driver and Microsoft Network Monitor 3, then I restarted the VPN and got it working! Might not be the same items, try to disable many and see if it works, because disabling only one of those two, didn't work. I had to disable a few. Let only enabled Client for Microsoft networks, File and Printers share for Microsoft networks, the IP version 4 and version 6, E/S controller and the (really not well translated) device of answer of detection...... (at least with Windows 7). Let only those 6 and enable one by one to see which ones are causing the issue. Sorry for the items list, I couldn't translate them very well, specially the last one. Hope this helps!

View solution in original post

Highlighted
New Contributor

Re: Cannot get adapter config on diagnose

and how do you open the hamachi network interface?

Highlighted
Active Contributor

Re: Cannot get adapter config on diagnose

I think Windows 10 still has Control Panel, right? (the older ones of course they do) If it doesn't, no idea haha. If it does, open it and go to Network and Sharing Center. Then in the left part of it, select Change network card settings (or something like that, I translated it) and there are the different interfaces you have on the computer.
Highlighted
New Contributor

Re: Cannot get adapter config on diagnose

how to go hamachi network interface?
Highlighted
Active Contributor

Re: Cannot get adapter config on diagnose

If you're asking how to get to the Hamachi Network Interface, just read my comment above. If it's not that, could you clarify what you need?
Highlighted
New Contributor

Re: Cannot get adapter config on diagnose

HELLO! My friend and I are using hamachi but we are having the same issue described above. Next to one of the users, it says "relayed tunnel." Where excatly is the hamachi network interface that you were talking about? Can you show us pictures step by step what you did to solve this? 

Highlighted
Active Contributor

Re: Cannot get adapter config on diagnose

Network and Sharing Center:

Sem Título.png

Change network card settings:

Capturar.PNG

There is it. Btw, sorry, that's in portuguese haha. If you want to translate, that's the language.

 

It should be on the folder behind the small window, which should be the one with the options you disable. But I'm sorry, I no longer have Hamachi installed. I had to always be disabling the network card because having it enabled would break my connection, and I didn't use it much, so I just uninstalled it. But should be there. One of those icons should be of the Hamachi Network Interface (might have some other name, I don't even remember that right, I just re-read my post and realized what I was talking about and it's here it should be.

 

Again, not sure how it's done on Windows 10. I don't have it yet. But from what I've seen when I use it on other computers, it's the same way. You go on Control Panel, then to Network and Sharing Center, Change network card settings, and the network cards should be there, then just go on their options and deselect the ones you want.