cancel
Showing results for 
Search instead for 
Did you mean: 
Azytronas
New Contributor

Hamachi Network adapter not present, can't install it.

I've tried reinstalling hundreds of times, it will not work, trust me. After installing, any time I try to join a network, I join it, and soon after I get a tunneling error yellow triangle message, if you go into the details, it says "Failed to connect to the network adapter. Peer is not accessible via VPN." So I thought the problem was that there is no Hamachi 2 adapter in the adapter settings, but when I try to add a driver through the steps in the FAQ, I need to use a hamachi.inf file, that is not present nor in my installation folder, neither in every other Hamachi folder.

 

Any help acquiring the hamachi.inf file?

18 REPLIES 18
NovaKross
New Contributor

Hi¡

i have that probem but, I had hamachi installed for a long time, and out of nowhere the network adapter, just one day the adapter disappeared, and tried reinstalling hamachi, using the CMD commands, and trying to install the adapter manually (which tells me that it can not find the file), I'm already frustrated, since I can not connect with my mates to play LAN :, (

 

Kryztoval
Active Contributor

This fixed my problem, thanks!! I was going crazy with this.
geeekdotnet
New Contributor

How did you fix this problem.  I have been working with the Support Services for over 6 hours over three days and they cannot seem to fix it.  I wish they had a better escalation process.  I am begging them to bump it to Level 3 support, Level 2 has worked on it for 2 hours.  Never have I seen any tech run 'hamachi-2.exe -add-tap "Hamachi"'.  However I have run it several times, without error, but the adapter never shows up.  I have also tried it in "administrator mode" for command prompt.  No errors, no success.  I have updated my windows 10 twice (two step process?).  It is now Windows 10 20H2 which I believe is the latest.  It doesn't seem to want to update anymore.  Uninstalled Hamachi, reinstalled, same problem.

AshC
GoTo Moderator

@geeekdotnet  Is this only affecting one machine, or are there multiple devices experiencing the failure?


Ash is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
DelsinPRO
New Contributor

...... what?

DelsinPRO
New Contributor

what is this supposed to even mean?!
DelsinPRO
New Contributor

the solution makes absolutely no sense

Tags (1)
freebeans
New Contributor

I can confirm this procedure does work for creating the necessary Network Adapter, but it may fail in some cases.

 

First of all, you should launch the Command Prompt as an administrator, else the command might fail.

 

Second, you should not issue the command before navigating to the proper folder which contains the hamachi-2.exe executable. You can navigate on the Command Prompt with the cd command.

 

Remember: this will only create a Network Adapter for Hamachi, and nothing else. If you already have a Network Adapter installed for Hamachi, this will not solve your problem.

_greentea_09
New Contributor

Did you download the Hamachi program in your external storage or windows local disk c?

 

If you did download it in a external storage like my friend the external storage name is data d(something like this)

I would recommend you to search up in your windows local disk c, in program files(x86), Logmeinhamachi, and see

whether the hamadrv.exe is in the x64 file.

 

Because for my friend he downloaded the file into his external storage but it automatically set up another one in the local disk c. (although there is a logmeinhamachi file in his external storage, the one didn't contain the hamadrv.exe file)

 

Then he was able to download the adapter in the device manager > choose network adapter > action > add legacy hardware > ... > but he browsed inside the disk c this time and it works. 

 

Hope this helps you.