Showing results for 
Search instead for 
Did you mean: 
New Contributor

Yellow Triangle shown when attempting to connect

I'm on Windows 10 and there's always a yellow triangle next to the network in Hamachi. It says it is a tunnel problem. How can I fix this? 

183 REPLIES 183
New Contributor

Indeed, hard for a VPN to run with no tunneling.


 Strange that the startup type is automatic, yet it doesn't run.


You may want to consider adding a line to your startup script to include 'net start "LogMeIn Hamachi 2.0 Tunneling Engine"'


you'll need to include the double quotes around the service name for windows to understand it as 1 service and not 2.


Thanks for the post, this clarified what I had suspected.

New Contributor

I think this is a bug in Hamachi2, and should be fixed by Logmein.


My Hamachi Tunneling Service did have startup type as "Automatic" and it started on every Windows power up.

But, for my machine, the service stop from time to time!


I notice that the service stop when it trying to connect to some of then "off line" or "bad connection" VPN client, (the green button blink and stop with yellow, or red). During retrying, sometime the service simply stop!


I can restart the service as mentioned above, but it should not happen like this. Hope that  there should release version "2.1" soon!


New Contributor

I have this issue on several of my Clients, however, hamachi2 starts anyway and eventually connects. I just  do not get the interface to pop-up until i manuall start hamachi2.


Based on this I suspect an addition of DependOnService stringwith the correct value(tcpip?,lanmanworkstation?,NetBIOS?, NetBT?) in the HKLM\SYSTEM\CurrentControlSet\Services\Hamachi2Svc key would solve the problem

Active Contributor

When you put the start of the UI it in the Startup folder it might get started before the Hamachi2 tunnel service is up and running.


Put a delay in front of it. There are other more elegant sollutions. But this simple one works for me.


C:\Windows\System32\cmd.exe /c sleep 20 && start "" /MIN "C:\Program Files\LogMeIn Hamachi\hamachi-2-ui.exe"


With regards

Hassan 22
New Contributor

any new solution, the previous solution solution doesn't work with me
Active Contributor

I wrote this little program for fixing the issue.

it set Hahachi service autostart to manual.
It start hamachi


Download link:

New Contributor

i got the best solution... in case you guys haven't notice at the services where the logmein thing is... it says at properties clearly what the path to the actual executable is... and that is hamachi tunneling exe not the ui one... and also you can see a -s at it... well ta da! make a shortcut to the exe(the one with tunneling engine thing:hamachi-2.exe) and add at path a -s. this also opens hamachi for me... i mean no need to use the other shortcut well at least for me...


Oh i added a download also in case you guys can't make it work... oh... and notice that the path to the downloaded shortcut i put is for my computer... change it accordingly to ur path.


New Contributor

You are a genius. I am on Win 7 and also worked  perfectly.


Thanks for taking the time to post!

New Contributor

I have exactly the same problem except none solution above helped me.


Here some screens:


and when i try to start hamachi gives me the error Failed to connect to the engiene.


Someone have a solution?


Im running win7x64 btw

Tags (1)
Active Contributor



Seems like the engine did not install in your system. Try the following and see if it will start hamachi.


Start > Run > cmd

in the comand prompt, key in the following exactly.

net start Hamachi2svc


If it does not work, the hamachi service process is not installed or diabled. Try using the file i posted earlier. If the service is diabled, it will enable it (to manual)


If above still doesn't work, reinstall hamachi. Otherwise, can't help.