cancel
Showing results for 
Search instead for 
Did you mean: 
RickyDee
Active Contributor

Need old installer for XP

I have 7 host computers that must run Windows XP (proprietary POS only works on XP for now). Logmein is working fine on these computer still (host software v4.1.0.9498) but I need to replace one of the computers and the current Logmein installer won't install on XP. Of course, Tech Supt was no help. Does anyone have an older installer. I'm convinced that if I can get it installed, it will work.

94 REPLIES 94
LW98115
Active Contributor

I was never able to locate a earlier version.... sorry I can't send you a link!

2Jeeps
New Contributor

Need Logmein Client for XP. Thank you.
LW98115
Active Contributor

I’ve not been able to locate a xp installer so still looking when I have the time...
Jimhyak2007
New Contributor

Requesting and begging - anyone who has a link to an old XP installer.!!

I am in same predicament with some XP boxes, Hoping you will share installer for v4.1.0.9498

ksld-jrosario
New Contributor

Hi Martinob,

 

Do you still have the LogMeIn XP SP3 installer available to share?

 

Thanks,

Joe

WowDigital
New Contributor

Give this a try - I think it will work on XP...

 

https://we.tl/t-B9IUM0nDDW

Jimhyak2007
New Contributor

Thanks
LW98115
Active Contributor

I was never able to locate the older xp install
MLerner
New Contributor

Jack000

Could you email me the older version of LogMeIn Pro that works with Win XP SP3?

My email is mll@lernerlaw.com.

Marty

MLerner
New Contributor

Same here
I need the logmein installer for WinXP SP3.
Since I mistakenly upgraded LogMeIn to its current version I get the same message as others -- i.e. no internet.
Please help!