cancel
Showing results for 
Search instead for 
Did you mean: 
GotoUser4711
Active Contributor

Microphone not working in Chromium with Debian

Hi,

 

I have problems with my microphone using your web-app in Chromium under Debian.

- I open app.gotomeeting.com and enter my meeting-id.
- I select computer and continue.
- I allow Chromium to access to my microphone.
- Select my microphone and speaker.
- I test both of them: Speaker plays music. Green bar responds to my voice.
- I start the meeting, wait for the organizer.
- Meeting is open, I hear everyone, my camera works (after allow it for Chromium), but my microphone does not work. GoTo says it does not have permissions.

Well, I gave GoTo the permission and it worked at the select-audio-screen.

 

I made further tests:
- The webcam works at the test-page https://de.webcamtests.com/
- The microphone works at the test-page https://de.mictests.com/
- Both of them works in a meeting by Cisco: https://vc.dwd.de/

 

My software:
- Debian 10
- Chromium 87.0.4280.141

 

My hardware:
- Laptop (Webcam is not detected by Debian, Microphone is detected, but does not work, Speaker works)
- Webcam Logitech C920: https://www.logitech.com/en-us/products/webcams/c920-pro-hd-webcam.960-000764.html

 

In a meeting some days ago, I could reload the meeting-page again and my microphone worked. But today this workaround does not work any more. In the microphone-list, is the not working laptop-microphone the first in the list, after that the Logitech is in the list. Perhaps this helps.

1 ACCEPTED SOLUTION

Accepted Solutions
GotoUser4711
Active Contributor

Re: Microphone not working in Chromium with Debian

Hi,

 

after many hours of investigation, I found a solution.

 

My system used ALSA for audio. I installed PulseAudio:

sudo apt-get install pulseaudio pavucontrol

and started it with

pulseaudio --exit-idle-time=-1 --daemonize

 

Now the microphone of my Logitech also works IN the meeting.

 

I wonder why ALSA worked in past IN the meeting, but now it doesn't. Due my live-system there were no changes in hard- or software on my side.  Very strange...

View solution in original post

8 REPLIES 8
GlennD
GoTo Manager

Re: Microphone not working in Chromium with Debian

Hi @GotoUser4711

 

I do not have a PC running Debian, but I do use Chrome and Chromium on Ubuntu to join and host GoToMeetings. I normally use a basic Logitech USB headset over the webcam microphone.

 

I would recommend deleting the current rules so that you are asked again to allow microphone and webcam access https://support.google.com/chrome/answer/2693767?co=GENIE.Platform%3DDesktop&hl=en

 

Either in your next meeting or if you join our test meeting you can check your audio hardware is working.

 

 

Glenn is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
GotoUser4711
Active Contributor

Re: Microphone not working in Chromium with Debian

Hi,

 

to submit correct bug reports, I started with a fresh default-profile in Chromium and the same version of Chromium for each meeting. So there are no rules or permissions for webcam/microphone saved (I verified this).

 

Regarding the hardware: The webcam/microphone from my laptop are not working in Debian, but the webcam/microphone from Logitech works with the same browser and the same settings without problems in webmeetings from Cisco. It even works in GoTo before I start the meeting. So I gave permission, saw that microphone and speaker works. The meetings starts and SURPRISE no microphone works.

 

This seems like a bug in GoTo.

GotoUser4711
Active Contributor

Re: Microphone not working in Chromium with Debian

Hi,

 

I made more tests:

I booted a Ubuntu-Live-DVD (version 20.10). I installed Google Chrome (version 88) and Google Chromium (version 88). In both browsers GoTo works without problems. My laptop-microphone is working and the logitech-webcam/microphone is working too.

Since I don't like GNOME, I also downloaded Lubuntu, which is Ubuntu, but with LXDE instead of GNOME. Same versions 20.10, 88, 88. I was surprised, that my laptop-microphone did not work here. Neither in de.mictests.com nor in GoTo. The logitech-webcam/microphone worked here too (not in GoTo meeting).

 

Although I don't want to use my laptop-microphone, this seems to be the problem with GoTo. In the select-audio-screen everything works in Goto. But if my laptop-microphone is not working (Debian and Lubuntu) no microphone at all is working in the meeting, even if it worked seconds before in the select-audio-screen.

GlennD
GoTo Manager

Re: Microphone not working in Chromium with Debian

Hi @GotoUser4711

 

Thank you for reporting your findings. I think your test show that the issue is related to how audio is being managed in the various Linux distributions rather than the GoToMeeting web app since you were successful using regular Ubuntu which also recognized your built-in audio hardware.

 

Glenn is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
GotoUser4711
Active Contributor

Re: Microphone not working in Chromium with Debian

Hi,


does this mean the issue will not fixed, because GoTo only works in Ubuntu, while Cisco Meeting App (vc.dwd.de) and other webmeetings works with many Linux distributions, (including Debian)?


Oh, and don't forget: GoTo worked some weeks ago in Debian too. While my operating system, browser and settings where the same (live-system from DVD) the only changed thing was your web app. I also find it strange, that microphone works before the meeting but no longer in the meeting.

GlennD
GoTo Manager

Re: Microphone not working in Chromium with Debian

@GotoUser4711

 

We develop and test our web app to work in Google Chrome specifically, independent of the operating system the browser is being used on. There is no Mac, Windows or Linux distro version of the Web App, everyone joining through it gets the exact same version. The only variation is the computer being used.

 

 

Glenn is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
GotoUser4711
Active Contributor

Re: Microphone not working in Chromium with Debian

Hi,

 

after many hours of investigation, I found a solution.

 

My system used ALSA for audio. I installed PulseAudio:

sudo apt-get install pulseaudio pavucontrol

and started it with

pulseaudio --exit-idle-time=-1 --daemonize

 

Now the microphone of my Logitech also works IN the meeting.

 

I wonder why ALSA worked in past IN the meeting, but now it doesn't. Due my live-system there were no changes in hard- or software on my side.  Very strange...

GlennD
GoTo Manager

Re: Microphone not working in Chromium with Debian

Thank you for reporting back and posting the solution.

 

Glenn is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!