cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor

GoToMyPC input not registering on client PC

I decided to give GoToMyPC a 7-Day trial as I use it for work and wanted to use it for personal. I installed it on my machine without hitch and I am able to log into the host machine without a problem. However, entering commands via the mouse or keyboard doesn't show on the client machine. If I disconnect and re-connect it will show that the input I did actually worked. As an example, I can click the start menu and it wont show the menu's. If I disconnect and reconnect, the menu will be there. It's quite odd as I can move my mouse freely, if I hover over a link it will give feedback of the text changing color....but if I click, I will not see the page load or another tab open unless I do the afforementioned disconnect method. I tried the connection wizard but I can't reliably see the results on the host PC (as I am not home currently and on the road). I went as far as to try the mobile app and I have the same issue. I was able to check that my browser had java enabled but I am not going to keep doing the disconnect process over and over as it's simply too tedious. Does anyone have any idea what the issue might be? The host PC is actually fairly new and it's what I use as a client PC to log into my work PC (host). My chrome and hardware drivers are constantly kept up to date. Any help would be great and if I can resolve this I may actually sub to this service. 

 

Thanks in advance. 

2 REPLIES 2
Highlighted
LogMeIn Contributor

Re: GoToMyPC input not registering on client PC

@Khilleus  If the connection isn't freezing completely on you, I'm wondering if what's happening is a Windows security setting that will freeze screen capture when accessing certain sensitive areas such as the start menu.  Are you able to re-install GoToMyPC on the host side by first saving the download, and then running the installer manually as the administrator? 

Highlighted
New Contributor

Re: GoToMyPC input not registering on client PC

Thank you for your reply, I will have to try this. I will look into it and share my results.