cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Re: Hamachi Network Adapter disappears in Windows 8.1


@Sean_K wrote:

You have to run these as administrator.  Ensure you are opening the command prompt as admin (right click)


Worked for me.

Thanks Sean.

New Contributor

Re: Hamachi Network Adapter disappears in Windows 8.1

Regarding Missing Hamachi Network Adapter and Windows 8.1

 

Install Hamachi as normal

 

If Adapter is missing

 

Add a device and choose Legacy device

 

Choose Network Adapter

 

Choose driver from the LogMeIn Hamachi Folder

 

Choose top Hamachi choice in folder

 

After install Completed

 

Go to the network adapters

 

Find the Unidentified Adapter

 

Rename Adapter to Hamachi

 

Restart Hamachi Service

 

Turn Hamachi Off then On

 

This resolved Win 8.1

New Contributor

Re: Hamachi Network Adapter disappears in Windows 8.1

I tried this method, but it did not work.

 

The only solution I have found is to reinstall the software every time the adaptor dissapears, which is daily now.

 

I'm looking for a VPN solution that's not Hamachi. I still have scars from the version that crashed every machine running windows 8 for days until it was repaired.

 

New Contributor

Re: Hamachi Network Adapter disappears in Windows 8.1

Could someone help me, I am not good at these technical things but I don't quite understand how you ''

can run the following commands from the command prompt within the Installation folder:

 

hamachi-2.exe --upd-tap

hamachi-2.exe --add-tap "Hamachi"

 

Then restarting the Hamachi Service."  

 

Where do I need to type these commands? In the CMD or...? because I don't understand how you type these commands Within the installation folder...

 

Thank you,

ThaReapZ

New Contributor

Re: Hamachi Network Adapter disappears in Windows 8.1

I can't rename the adapter. It says that an adapter with the same name already exists although I can't see it in the network adapters. Do you know a solution?

New Contributor

Re: Hamachi Network Adapter disappears in Windows 8.1

 
Active Contributor

Re: Hamachi Network Adapter disappears in Windows 8.1

tried that but got an unspecific error on the last screen of the install of network adapter.
Active Contributor

Re: Hamachi Network Adapter disappears in Windows 8.1

doesn't work get existing tap found, internal name []

 

C:\Program Files (x86)\LogMeIn Hamachi>hamachi-2.exe --add-tap "Hamachi"
12/05 13:48:02.508 [2172] tap: add_tapdev(Hamachi)
12/05 13:48:02.526 [2172] tap: list_netdev_win32() ..
12/05 13:48:02.575 [2172] tap: existing tap found, internal name []

C:\Program Files (x86)\LogMeIn Hamachi>

 

 

 

 

New Contributor

Re: Hamachi Network Adapter disappears in Windows 8.1

 
New Contributor

Re: Hamachi Network Adapter disappears in Windows 8.1

I was having the same issue here for weeks:

 

C:\Program Files (x86)\LogMeIn Hamachi>hamachi-2.exe --add-tap "Hamachi"
12/05 13:48:02.508 [2172] tap: add_tapdev(Hamachi)
12/05 13:48:02.526 [2172] tap: list_netdev_win32() ..
12/05 13:48:02.575 [2172] tap: existing tap found, internal name []

 

 

Apparently the adapter was still listed in the registry after an update, therefore the name Hamachi couldn't be used by the installer. So it didn't matter if we attempted the name change from command line, it was registered in the system.

 

I fix it by uninstalling Hamachi and deleting some entries in the registry, made an export of the keys for precaution and delete (not checked if the deletion of all of them is necessary, please go in order and test after each deletion):

 

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Network\{BIG HEX NUMBER}\Descriptions\

Here are listed all the registered adapters, 

Delete: "LogMeIn Hamachi Virtual Ethernet Adapter"

 

On the following, search for "Hamachi", backup and delete each entry (sometimes are listed as "DNE Hamachi"):

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\DNE\Parameters\Adapters\

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Network\

 

HKEY_LOCAL_MACHINE\SYSTEM\Setup\Upgrade\NDIS\NetAdapters\

HKEY_LOCAL_MACHINE\SYSTEM\Setup\Upgrade\NDIS\ConnectionNameRoot\

 

To verify that it worked, go to the Network Adapters panel and rename the main WiFi or ethernet adapter to "Hamachi", if there is no error, change the adapter's name back to something different than "Hamachi" and install Hamachi.

 

Hope it works for you

 

Regards,

Florentino Montalvo