cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor

Network adapters gone after uninstalling Hamachi?

I think Hamachi has royally screwed up my computer ever since I uninstalled it. I installed on Oct. 18th because I know it's an easier solution than port forwarding and setting up a static IP, but I had a few problems with it a couple days ago so I uninstalled / reinstalled, and had it working again until last night.

 

I turned off the automatic startup for Hamachi, but when I turned my computer on yesterday I didn't have wifi at all. I checked my network adapters, nothing but Hamachi / Ethernet. My other computers in the house were working fine. So I tried to turn on Hamachi to see if it would help, tried resetting, nothing. Next I uninstalled it, restarted, still no wifi. Now my computer only had an ethernet adapter and no hamachi adapter. I did some more digging and went into my devices, it didn't show up there either until I found out it was hidden. Clicked properties, and got error 45 : "Currently, this hardware device is not connected to the computer. (Code 45)"  ??????

 

Now I'm really confused, because this is a brand new laptop, never been bumped touched dropped etc and it's been working perfectly fine until hamachi, so I know it's not a direct hardware problem. I found only two other people by googling that had the same problem, one never found a solution, and the other couldn't find a fix besides a system restore. I tried everything, made sure Hamachi was fully uninstalled, checked my registry, did an sfc / dism scan, tried updating my drivers, EVERYTHING. Nothing worked. 

 

Finally I decided to just uninstall the drivers through the device manager, and reinstall them...but it never showed up again since then. It's completely gone, not detected, not hidden anymore, completely vanished. Luckily I don't have a huge amount of things I needed to pull off my laptop, so I've got everything except my work program on an external drive, and plan to reformat in the next few days once I transfer that to my work computer. If anyone has any ideas on how to fix this until then though I'm all ears...I've had nothing but trouble from this program, even when I used to use it years ago...this is the worst computer problem I've ever had though, praying it didn't completely fry my adapter somehow and everything just fixes itself on a full restore..