cancel
Showing results for 
Search instead for 
Did you mean: 
H4X0R46
New Contributor

Slow internet speeds after installing Hamachi

I've been having this issue for so long now! For some reason, my internet is blazing fast until I install Hamachi. Certain website downloads are affected but others aren't. for instance, downloading a zip file from "downloads.oneplus.com" WITHOUT Hamachi shows 3 minutes left. AFTER installing Hamachi, that same file now says 20 Minutes.... Same issue happens with Microsoft's download servers, when trying to download the Windows 10 iso, Hamachi just DESTROYS the download speed when my internet is more than capable of downloading large files quickly!

 

Even uninstalling Hamachi leaves the same affect, almost like there's something left in the system that causes this, registry data maybe? Any pointers?

61 REPLIES 61
carlossgv
New Contributor

I found a way to keep Hamachi and maintain your internet speed while you are not using it

 

Go to Services (Windows Search Bar: services.msc) and look up for LogMeIn Hamachi Tunneling Engine, disable it and restart the computer. It worked for me, if I need to use Hamachi again I'll enable it just for the time being. This way at least you won't have to format the OS.

 

Hope it helps! Is not the ultimate solution but it works.

carlossgv
New Contributor

I found a way to keep Hamachi and maintain your internet speed while you are not using it. 



Go to Services (Windows Search Bar: services.msc) and look up for LogMeIn Hamachi Tunneling Engine, disable it and restart the computer. It worked for me, if I need to use Hamachi again I'll enable it just for the time being. This way at least you won't have to format the OS.



Hope it helps! Is not the ultimate solution but it works.
woowoowoo
New Contributor

That workaround did not work for me.

Hiddenbonus
New Contributor

After installing hamachi my internet speed has become much slower. My speeds used to be 200Mbps on download and 20Mbps on upload and now they are 20Mbps download and 8Mbps upload even after uninstalling hamachi the same problem persists. This problem has been ongoing ever since I downloaded hamachi. Help is greatly appreciated Smiley Sad

Tags (3)
oyvindhauge
New Contributor

Try this to check the status of Receive Window Auto-Tuning Level

netsh interface tcp show global

and if it is disabled, turn it on with

netsh interface tcp set global autotuninglevel=normal

This helped me and two mates. The settings need to be run with admin rights cmd  (and shift+ctrl when you run it).

As far as we understand it you would most likely want Receive-Side Scaling State enabled as well.

netsh interface tcp set global rss=enabled

We have not tested Hamachi after changing these settings. Nevertheless, just wanted to share because this problem was making us crazy.

Style1
New Contributor

My cousing had been troubleshooting this for a few days and after starting to get involved in the troubleshooting the same problem occured on my main computer as well. There was no chance to increase the download above 1.3MBs (got 200/200 connection), unless downloading from a service that uses swarm tech (i.e Steam, Origin etc).

 

After backtracking we came back to Hamachi and this thread. We finally found the solution that worked for us. It seems installing Hamachin changes the TCP Global Parameters. To check/fix this, do the following:

 

SOLUTION:

Start -> Run -> CMD (as administrator to buypass the UAC)

then type the following command to show what parameters your current TCP has:

netsh interface tcp show global

This should give you a list over the TCP parameters, the ones Hamachi seems to change are these two:

Receive-Side Scaling State & Receive Window Auto-Tuning Level. Recieve-Side Scaling State was set to 'disabled' and Recieve Window Auto-Tuning Level was set to 'disabled'

 

Type the following commands in the CMD to change this:

netsh int tcp set global autotuninglevel=normal (Response should be OK.)

netsh int tcp set global rss=enabled (Response should be OK.)

 

Reboot shouldn't be needed after, but if you encounter problems do it. We didn't test Hamachi after this because we uninstalled it so I don't know how it works after this change.

 

I have no idea why Hamachi changes these parameters on some/all computers? When we checked other hosts in our network running the same OS without hamachi these parameters where unchanged and download speed OK.

Sjaco
New Contributor

That did it. That fixed my VM that I am running it on. I am now getting the speeds I saw before installing Hamachi. Thank you for the help!!!

Former Member
Not applicable

HOLY CRAP!,  This actually solved my internet problems! I've been dealing with internet issues for months now. I would get speeds anywhare from 30 mbps to 200, while my acctual internet speed it about 500 mbps. I now get a solid 500 mbps.

Thank you so much, best regards


-Bosky

dprice92
New Contributor

Just wanted to say thanks, this actually worked. I've had this issue before and reinstalling windows was the only thing that fixed it, but this seems to have solved it for me.

sebish
New Contributor

This really is the fix. Love you man!

 

I cannot believe that something malicious is still available to download. Logmein took hamachi and turned it into a strange looking virus and does not provide any support. I was that close to reinstall windows just because of that *** tool.

 

Just create a VPN with you routers guys. Never install this.