Showing results for 
Search instead for 
Did you mean: 
New Contributor

Slow internet speeds after installing Hamachi

I've been having this issue for so long now! For some reason, my internet is blazing fast until I install Hamachi. Certain website downloads are affected but others aren't. for instance, downloading a zip file from "" WITHOUT Hamachi shows 3 minutes left. AFTER installing Hamachi, that same file now says 20 Minutes.... Same issue happens with Microsoft's download servers, when trying to download the Windows 10 iso, Hamachi just DESTROYS the download speed when my internet is more than capable of downloading large files quickly!


Even uninstalling Hamachi leaves the same affect, almost like there's something left in the system that causes this, registry data maybe? Any pointers?

New Contributor

I setup hamachi as discussed here . The objective was  to router all traffic from computer B through computer A.


This works, but the internet is very slow and I mean dialup slow. I get 'waiting for tunnel' for at-least 10 seconds after which website loads slowly. 


I have 100mbps connection, so its not my connection speed.

GoTo Moderator

Hi @hanamura

If you have a paid Hamachi subscription there should be no connection delays.  This is only a restriction of the Free version.

Ash is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
New Contributor

Mate thx for the fix my internet in games was so bad I went from gigabit 0 ping to damm like 100 ping the last time this happened I had to reinstall everying from a factory reset this fix I'm gonna keep in a txt file if you don't mind

@Style1 wrote:

My cousing had been troubleshooting this for a few days and after starting to get involved in the troubleshooting the same problem occured on my main computer as well. There was no chance to increase the download above 1.3MBs (got 200/200 connection), unless downloading from a service that uses swarm tech (i.e Steam, Origin etc).


After backtracking we came back to Hamachi and this thread. We finally found the solution that worked for us. It seems installing Hamachin changes the TCP Global Parameters. To check/fix this, do the following:



Start -> Run -> CMD (as administrator to buypass the UAC)

then type the following command to show what parameters your current TCP has:

netsh interface tcp show global

This should give you a list over the TCP parameters, the ones Hamachi seems to change are these two:

Receive-Side Scaling State & Receive Window Auto-Tuning Level. Recieve-Side Scaling State was set to 'disabled' and Recieve Window Auto-Tuning Level was set to 'disabled'


Type the following commands in the CMD to change this:

netsh int tcp set global autotuninglevel=normal (Response should be OK.)

netsh int tcp set global rss=enabled (Response should be OK.)


Reboot shouldn't be needed after, but if you encounter problems do it. We didn't test Hamachi after this because we uninstalled it so I don't know how it works after this change.


I have no idea why Hamachi changes these parameters on some/all computers? When we checked other hosts in our network running the same OS without hamachi these parameters where unchanged and download speed OK.


New Contributor

This seems to be a bug (or feature?) that other people, including myself, have had.  My Internet speed before installing is 200.  After installing is 50.  After UNINSTALLING is still 50.  You have to manually un-do the changes made to your computer that Hamachi made.


Here is the solution:


This solution works for me.  Internet went back to 200 after doing this.


I REALLY wish that LogMeIn support would chime in officially regarding this.  I have not contacted them myself, but someone else in that thread did, and they reported that support would not acknowledge it.


GoTo Moderator

Hi everyone,

I apologize for the delays, and expect the next version to have native API calls instead of netsh background configurations.  Until that time (as mentioned previously), you can run the following commands to resolve:

netsh int tcp set global autotuninglevel=normal
netsh int tcp set global rss=enabled

Ash is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
New Contributor

Hi everyone,

The solution works great for me and my download speed is back to normal, BUT I still have the same problem with my UPLOAD SPEED. Same as occurred with download speed after installing Hamachi the upload speed is down to half of normal speed.
I think there be similar CMD netsh commands to restore upload speed. Can you help me with this?
Active Contributor

You are my Hero, finally i found the issue after i already reinstalled windows! 
But my Upload is still broken, should be on 50 Mbps and its on 10Mbps - any solving on this?

We need to bring this information to Hamachi, it caused on both of my installations this issue! 


Active Contributor

But my Upload is still slow since i installed Hamachi, what can fix this?

New Contributor

Glad our technical investigations were of help to others 🙂


I think Hamachi are aware. One of my mates also posted the problem/solution on the forums, and if I remember correctly, he got an answer from one of the Hamachi employees stating they would fix it in some upcoming release. I believe, this was a few weeks ago (and pretty long after we posted).

New Contributor

I worked for me too, thanks a lot but the upload speed got cut in about half after I applied the netsh commands. If there is a fix for this asw please tell us, if not i guess we`ll just have to wait for the next update.

Thanks 🙂