cancel
Showing results for 
Search instead for 
Did you mean: 
gregdenis
New Contributor

Safari browser keeps downloading client installer

Hello,

 

I am trying to setup an application called Remote Desktop Manager which is application configured to use Logmein desktop shortcuts for a few workstations. While these shortcuts will work for users running Windows, when I try to do the same on a Mac workstation, the Safari browser keeps trying to download the Logmein Client installer despite having this already installed and the shortcuts do not work as expected.

 

I have checked the usual security settings to allow the Logmein Client application and also copied this over to the Applications folder yet this issue still seems to persist, am I missing something else or is there knowledge base documentation that covers how to set this up on a Mac?

2 REPLIES 2
AshC
LogMeIn Contributor

Re: Safari browser keeps downloading client installer

@gregdenis  Sorry, I'm not aware of Mac-specific instructions for this.  Have you tried using Chrome as the default browser there? 

gregdenis
New Contributor

Re: Safari browser keeps downloading client installer

Hello AshC,

 

Thanks, I tried using Chrome as the default browser and I get the same issue where it will say the Logmein Client needs to be installed first in order to access the full remote control feature.

 

It will download the installer for the application which will run fine if I launch it manually and the application is listed in the installed applications yet when I try to use the browser shortcuts in either Safari or Chrome, it will keep saying it is not installed. 

gregdenis_0-1637589601925.png

On Windows machines this will work and setting this up is really straightforward process on Windows, I am not sure why there's some issue with getting this to work on Macs unless there's some capability issue with getting this feature to work on this platform. 

 

From the looks of it, both browsers appear to have this same issue where they are unable to access the installed application and prompt to install the Logmein Client. I am not sure if there's some accessibility setting or some other setting that I need to enable in order to get this to work.