Showing results for 
Search instead for 
Did you mean: 
Active Contributor

Wake on LAN - Everything works except through LMI. Potentially interesting Registry findings?



I know that WoL is sometimes difficult to get working, and there has sometimes been a contentious history between LMI and WoL.  However, I have always been able to (eventually) work around the issues, and I have been maintaining dozens of computers for years which I have been able to remotely switch on through LMI.  But I have a couple new computers that I just installed, and there seems to be nothing that I can do to convince LMI that they are able to be switched on remotely - even though WoL works fine using other software.


I think the most important fact again is that I am able to WoL these computers in question without any issue at all when using other WoL software (other than LMI).  So I'm about as confident that I can be that I have the myriad of potential WoL-killing options configured correctly.  LMI control panel, BIOS, deep sleep blocked, numerous NIC options in device manager, fast startup disabled, etc.  There are lots of other switched on computers in the same LAN as these two new computers in question.  I also have 0 issues using LMI to remotely control these computers once they are already awake.  But when these two new computers are shut down or asleep, LMI just forever shows them as unable to be remotely switched on (see image).




It used to be a workaround that I could convince LMI to allow the remote switching on by: disabling WoL in the LMI control panel, reboot the computer, re-enable WoL in the LMI control panel, and then reboot the computer again.  But that hasn't worked this time.  I also tried switching LMI on and off and restarting lots of times, and also uninstalling and reinstalling LMI.


Something I noticed in further debugging is that registry keys seem different between these 2 new computers and other computers which are working fine.  Specifically, Computer\HKEY_LOCAL_MACHINE\SOFTWARE\LogMeIn\V5\WebSvc\CachedWolStatus has a value of 1 on all of the other computers that I checked, but it has a value of 3 on these two computers which are giving me WoL issues.  If I disable WoL from the LMI control panel, this registry key switches to a value of 2.  If I re-enable WoL from the LMI control panel, this registry key switches back to a value of 3.  If I manually set this registry key to a value of 1 to match other computers, it gets automatically reset to 3 any time I restart the computer or restart the LMI service.  The CachedWolParams key matches other computers (except obviously for the host MAC address values).


Can someone(s) confirm what this registry key is on your computers which are able to be remotely switched on through LMI?


Can LogMeIn ( @AshC ?) comment and/or recommend other steps that I can take to try to resolve this issue?

Active Contributor

Well I guess no one wanted to help 🙁, but I'll update with findings in case it helps someone else who may be experiencing the same issue as me.


After spending ~80 minutes on the phone with LMI Support (thanks, Edwin), it appears that maybe LMI doesn't support "Modern Standby" (link to Microsoft info). 


Apparently Modern Standby is not meant to be disabled, as it does not appear that Microsoft gives us any official method to do so.  Reading through some forums, I find that there was an older registry hack to disable Modern Standby, but that stopped working at some point maybe around Win 10 2004.  When I use a newer registry hack to disable Modern Standby (link to ElevenForums), the LMI CachedWolStatus registry key gets the value of 1 like all of my other computers, and WoL does then immediately work through LMI.  So that would seem to confirm that LMI doesn't support Modern Standby.  But the differences seem kind of trivial to me, because again WoL works for these computers (whether Modern Standby is on or not) when I'm using other tools.  Ultimately all we're doing is sending a magic packet to the NIC, right?


However, even if I wanted to use this workaround of turning Modern Standby off, the problem remains that my Dell BIOS do not seem to support Modern Standby being off.  When I use the above registry hack to turn Modern Standby off, it seems impossible to put the computer to sleep, and I also get warnings from BitLocker (and I'm not even using BitLocker).  I'm going to open a support ticket with Dell, and I'm hoping that LogMeIn Support will escalate my ticket.

Active Contributor

Update - Dell has indicated that they no longer support Modern Standby being disabled.


I still have a ticket open with GoTo/LMI, and I'm hoping that they can at least give me a workaround.  These computers will  wake up if they receive the WoL magic packet (or pattern match), so I really just need LMI to send that packet.   I have to assume that this will become a widespread issue as computer manufacturers (apparently) deprecate support for anything that isn't Modern Standby.

Active Contributor

For anyone finding this thread later, here is the link to Dell's whitepaper describing that Modern Standby cannot be disabled and legacy S3 functionality cannot be restored.  (link)


The most recent response from GoTo Support is that Modern Standby is not supported, and they have no plans of ever supporting it.  However, I am trying to get GoTo Support to understand that this would mean that LogMeIn's wake on LAN functionality would then not be compatible with any Dell computer going forward (~50 million computers per year).  I have not specifically researched, but I imagine that the other major computer manufacturers will be heading the Modern Standby route as well, since it is really Microsoft pushing it.  So really my only options would be A) LogMeIn develops support for Modern Standby, or B) I have no choice but to start working toward using a different remote access software.