Contact list should show Company Name instead of "Unnamed"

Showing results for 
Search instead for 
Did you mean: 
Make sure you Kudo Ideas you would like to see implemented

Contact list should show Company Name instead of "Unnamed"

0 Kudos

Contact list should show Company Name instead of "Unnamed"

Whenever i have a contact in my GoTo contact list which has a Company Name, but no First Name or Last Name, it shows up in my contact list as "Unnamed". This is not helpful to the user in any scenario I can imagine, especially when there are a lot of such Companies in the list. This happens a lot.

For example "Verizon Support"; I do not have a first name or a last name to supply here, because I have no idea who I'm going to get when I call that number. It is not useful to me for this entry to show up as "Unnamed"; it should show up as "Verizon Support".

This is very easy to achieve programatically. I know because I'm a software developer myself. Also, you are already essentially doing this with the first name and last name. For example if there is an entry called Mary Jones, and both first name and last name are present, it displays under "M" as "Mary Jones", but if only the last name, Jones, is present, it shows up as Jones. Just do the same thing for Company name if niether first or last name is present.

Better yet, include entries multiples times in the list to make them easier to find. This is what I do in my own applications. For example, if you have an entry of Mary Jones at American Family Insurance, display it three times as "Mary Jones - American Family Insurance", "Jones, Mary - American Family Insurance", and also "American Family Insurance - Mary Jones". Perhaps not everyone will want to see their list this way, but I think you will find that people like it. If you want this behavior to be optional, simply add a setting called "List contacts multiple times" or something like that.

But at the very least, please do not list anything as "Unnamed" unless there is no first name, lastname OR company name; just display whatever name you have available.

As a work-around, I have had to copy the Company Name into the First Name on all of my contacts, and remember to do this for each new contact I create, or whenever I change a contact. This works, but it's clunky and inconvenient.

1 Comment
GoTo Moderator
Status changed to: Accepted

@RickAtKnowWare Thanks for sharing this. This is a known issue, a fix is coming up in the future. 


The field should be shown as:

Phone Number