Showing results for 
Search instead for 
Did you mean: 
New Contributor

Mac Unattended Access Broken

I'm trying to support my mother's new iMac M1 Mac OSX Big Sur. I set up unattended access several times, but over time it becomes unavailable again. I now have multiple instances of her computer in my account list but all of them always show offline. I can connect via on-demand remote session but it's a pain for her each time and she needs my help with unattended access. I just need to be able to help my mom and this should not be so hard to do. It worked on her old Mac but apparently, it's not ready for the new Macs.


To troubleshoot this, I've tried various things:


  • I can reinstall unattended access, using the install link to get it to work, but it will become disconnected. The app icon does not show up in the top menu bar when this occurs but it does initially after a reinstall.
    • When trying to install UA a window pop up warning "“G2AxCustomer.pkg” can’t be opened because Apple cannot check it for malicious software" and "This software needs to be updated. Contact the developer for more information. Chrome downloaded this file today at 4:36 PM from" 
    • I can then go to Settings > Privacy and Security to allow the install but it shows ""G2AxCustomer.pkg”  was blocked from use because it is not from an identified developer".
    •  When clicking "Open Anayway", I get another window with the same message but it allows me to open the UA installer package.
    •  This works temporarily but again, the computer will go offline for good after reboot or some time.
  • I've checked privacy settings and permissions.
    • GotoAssist Customer has permissions under Privacy > Screen Recording and Accessibility.
    • I read something that the g2ax_launchagent_customer needs the same permissions as the above, but this file does not exist on the system. I tried manually adding it but this does not work.
    • There's an article for Big Sur that suggests GotoAssistRemoteSupport needs to be given the same permissions as above, but again, this file/app does not exist on the system. Where is this file in the install package? 

At this point, it appears GotoAssist Unattended Access is not going to work on new Apple Mac computers. Does anyone have a workaround or can someone confirm that it's in fact broken, so I can stop pounding my head against this wall? 



Retired GoTo Contributor

Re: Mac Unattended Access Broken

Hi @surfnmtns 

Sorry for all the set up trouble there. 


I have seen some of the settings you enabled revert, if the admin Mac user does not follow up after install with : System Preferences > Security & Privacy > Privacy > Full Disk Access  > GoToAssistRemoteSupport


Do you recall if this was double checked post-installation? 

Ash is a member of the LastPass Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
New Contributor

Re: Mac Unattended Access Broken

@AshC, I checked the settings and they did not revert. I think there is some confusion in your reply. As noted in my initial post, I do not see the "GotoAssistRemoteSupport" app anywhere in the Privacy settings and searching for it in Spotlight finds nothing either. It's not there after re/installing the unsigned G2AxCustomer.pkg either. The only app that is available to give permissions to is "GoToAssist Customer (1702).app".

I don't know why the app is unsigned or from an "identified developer". This should not be the case for an app that has remote control permissions on a computer. This was not the case with other OSX versions. Is this expected for the version that works on Big Sur?