Showing results for 
Search instead for 
Did you mean: 
New Contributor

GoToWebinar API Support



It seems that the Access Token that's returned by the GoToWebinar API has increased from 28 chars to  909 chars sometime around 1AM PDT. It caused our systems to error out as it overflowed the database colum.


I have expanded the column in our database and it's now working again but why the sudden change? Do you really need an Access Token to be that long, especially one that expires within an hour? Ironically enough the Refresh Token that's valid for a month is still 32 chars.



New Contributor

I would like to post an answer I recieved a response from the response


So basic flow here would be:

  • Obtain Authorization Code using browser
  • Feed/redirect the access code to your application somehow
  • Exchange code for an Access Token and Refresh Token
  • Store Refresh Token
  • Use refresh token once a day to get a new Access Token payload
  • Always replace the stored Refresh token in the payload, even though they will be the same most of the time

If this flow is done properly, you should not need to login using the browser again, but it is good to always have the ability to feed your app a new code just in case




Maybe this help someone.

Also the reason for the

    "error": "invalid_request",
    "error_description": "Required parameter(s) missing or wrong."

Error was that the redirect_url was not the same I had in the access token request. Mybe that helps someone

// use the same redirect_uri here
curl --location --request POST '' \
--header 'Authorization: Basic <BASE64 client_id : client_secret>' \
--header 'Accept: application/json' \
--header 'Content-Type: application/x-www-form-urlencoded' \
--data-urlencode 'grant_type=authorization_code' \
--data-urlencode 'code={CODE}' \
--data-urlencode 'redirect_uri='
New Contributor



I am trying to register users via the API endpoint{organizerKey}/webinars/{webinarKey}/registrants with a test body of


{"firstName": "Testname","lastName": "Lastname'","email": ""}


I always get the error "Your request could not be processed because the request body is not parsable".


I sticked to the instructions here, tried with "Accept: application/json" and "Accept: application/vnd.citrix.g2wapi-v1.1+json" in the header.


Does anybody know this error and what could case it?

Tags (1)
New Contributor

No problem in Postman calling the API REST:

with Headers: Accept, Authorization, Cache-Control, Content-Type and Host and with Parameters: fromTime and toTime.   The results are OK.

But when I try this in code, CLASSIC ASP calling MSXML2.ServerXMLHTTP.6.0 REST, the result is:


{"errorId":"f186c7ac-a8be-4fa3-a72a-63b68f027dce","requestId":null,"timeStamp":1614797938102,"reason":"","errorCode":"","description":"Required DateTime parameter 'fromTime' is not present","incident":"1048515592356393472","details":null}


This is the code:


url = ""

Dim oXMLHttp
Set oXMLHttp=Server.Createobject("MSXML2.ServerXMLHTTP.6.0") "GET", url, false
oXMLHttp.setRequestHeader "Accept", "application/json"
oXMLHttp.setRequestHeader "Authorization", authorization_bearer_code
oXMLHTTP.setRequestHeader "Cache-Control", "no-cache"
oXMLHttp.setRequestHeader "Content-Type", "application/x-www-form-urlencoded"
'oXMLHTTP.setRequestHeader "Content-Type", "application/json;charset=UTF-8"
oXMLHTTP.setRequestHeader "Host", ""

FromTime =Server.UrlEncode("2021-02-27T00:00:00Z")
ToTime =Server.UrlEncode("2021-03-03T00:00:00Z")
strData = "fromTime=" & FromTime & "&toTime=" & ToTime & ""


oXMLHttp.send strData
response.write oXMLHttp.responseText
Set oXMLHttp = Nothing
Response.status = 200



Can u help me, please?

The authorization_bearer_code is obtained in the same way, and the call is correct.



Thanks in advance




New Contributor

Hi folks,


I'm using this API to create a webinar and I made someone else a host.


But when I hit the following API to update the meeting, I'm not able to do that even if I'm an admin.


I can't even hit other APIs  to add co-organizers like

It says:

"Authentication succeeded, but access to the requested resource is denied."


Is there any special permission for admin so that I can do this stuff with my account. The problem is only when I make someone else a host and trying to update the webinar.




GoTo Moderator

Hi Aditya ,

I'm not certain you can update webinar events as an 'account administrator', though you may be able to get an answer from the API team here:

Ash is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
Valued Contributor

They offer a lot of plug and play integrations.

Fran Simon
Engagement Strategies
New Contributor

Can you please help me with below scenario?


1. I want to create webinar by enabling ManualApproval during registration.

2. I want to fetch all the registrants of the webinar and verify if they have entered a passcode during registration. If so, I need to approve the registrant. 


As far I understood, when user registers he will be in WAITING state. 

Is there any API to change the status of registrant from WAITING to APPROVED?


Thanks in advance





GoTo Moderator

@rmohan I'm not aware of any API calls like that, but you will want to reference the developer site for all of these inquiries:

Ash is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
New Contributor

Did you ever find a solution to this? What are you using for your webhooks?

New Contributor

Is it intended that the organizerKey is not needed? I tried using `/rest/v2/organizers/{organizerKey}/webinars` endpoint and its seems the result is based off the fromTime, toTime and the token. I can pretty much put any value that is not blank to the organizerKey and it still works.