cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Re: Failed to connect to Hamachi servers

PUT on your DNS 8.8.8.8

and will join

New Contributor

Re: Failed to connect to Hamachi servers

cannot connect in LogMyIn login servers  ? 

 

New Contributor

Re: Failed to connect to Hamachi servers

I have done the 8 steps where you delete the server configuration folder (I also checked to see if new ones were made), I have also modified Norton's firewall to allow Hamachi. But it STILL says it can't connect!

New Contributor

Re: Failed to connect to Hamachi servers

Hello. I have tried all of the above. Here is my log after reinstalling: 

 

12/09 14:25:26.179 [3816] win32_main: EngineConfigDir [C:\Documents and Settings\LocalService\Local Settings\Application Data\LogMeIn Hamachi]
12/09 14:25:26.219 [3760] svc: entering START_PENDING mode ..
12/09 14:25:26.289 [3760] cfg: cannot open [C:\Documents and Settings\LocalService\Local Settings\Application Data\LogMeIn Hamachi\h2-engine-override.cfg]
12/09 14:25:26.299 [3760] dbg: deploy_id '3F84A587-C902-49F3-904A-E34A79D6BE46' parse ok
12/09 14:25:27.070 [3760] starting up ..
12/09 14:25:27.080 [3760] sys: version WXP-SP3-2.2.0.279
12/09 14:25:27.090 [3760] sys: os version 5.1.2600 sp 3.0 suite 0100 product 01, os_str: [WXP-SP3]
12/09 14:25:27.100 [3760] cfg: cannot open [C:\Documents and Settings\LocalService\Local Settings\Application Data\LogMeIn Hamachi\h2-engine.ini]
12/09 14:25:27.150 [3760] vpn: IPv6 support is: 2
12/09 14:25:27.190 [3760] ipc: init() ok
12/09 14:25:27.200 [3760] sys: initializing vpn domains, vpn-reinstall = 0 ..
12/09 14:25:27.220 [3760] tap: new tap: Hamachi
12/09 14:25:27.230 [3760] vpn: added [Hamachi] domain (not roaming)
12/09 14:25:27.251 [3760] dbg: setup_vpn_domain [Hamachi]
12/09 14:25:27.261 [3760] dbg: vpn_domain::config - [Hamachi]
12/09 14:25:27.271 [3760] vpn: switched [Hamachi] domain into L3 mode, 0.0.0.0/0.0.0.0
12/09 14:25:27.281 [3760] dbg: enable(Hamachi), locked: 0
12/09 14:25:27.311 [3760] vpn: domain [Hamachi] -> 'VPN_opening'
12/09 14:25:27.431 [3760] vpn: enabling [Hamachi] domain ..
12/09 14:25:27.441 [3760] tap: win32_set_hw_tapdev(Hamachi) ..
12/09 14:25:27.451 [3760] tap: list_netdev_win32() ..
12/09 14:25:27.581 [3760] tap: job [Hamachi, JOB_set_tapdev, 1] start thread ..
12/09 14:25:27.591 [3760] vpn: added [Null] domain (not roaming)
12/09 14:25:27.601 [3088] tap: job [Hamachi, JOB_set_tapdev, 1] thread started
12/09 14:25:27.611 [3760] dbg: setup_vpn_domain [Null]
12/09 14:25:27.621 [3760] dbg: vpn_domain::config - [Null]
12/09 14:25:27.641 [3088] tap: set_tapdev(Hamachi, up) ..
12/09 14:25:27.651 [3760] lge: init_logon_events
12/09 14:25:27.661 [3088] tap: list_netdev_win32() ..
12/09 14:25:27.681 [3760] lge: init win32 poll logon events
12/09 14:25:27.741 [3760] upd: fetching version info, [http://secure.logmein.com/versioncheck_hamachi.asp?os=win32&ver=2.2.0.279&lang=en&auto=yes] ..
12/09 14:25:27.781 [3088] tap: device found, status disabled, not running
12/09 14:25:27.801 [3088] vpn: enabling tap device ..
12/09 14:25:27.811 [3088] tap: do_status(ROOT\NET\0001, 1) ..
12/09 14:25:27.821 [3760] sys: connmgr_go_online, reconnect 1
12/09 14:25:27.871 [3760] svc: entering RUNNING mode ..
12/09 14:25:27.881 [3760] svc: entered RUNNING mode
12/09 14:25:28.382 [3760] ses: on_conn_state(connected, 0x0)
12/09 14:25:28.592 [3760] ses: select conn mode 'dns lb'
12/09 14:25:28.612 [3760] ses: go_offline, keep_tunnels 1, login_on_relaunch 0, actual state 4 ..
12/09 14:25:28.843 [3760] sys: go_online, reconnect 1
12/09 14:25:28.863 [3760] ses: resolving hamachi-dc.logmein-gateway.com ..
12/09 14:25:29.043 [3760] upd: on_conn_state(connected, 0x0) - 2
12/09 14:25:29.173 [3760] upd: >> 224 bytes
12/09 14:25:29.193 [3760] upd: http transfer completed
12/09 14:25:29.213 [3760] upd: version [2.2.0.279]
12/09 14:25:29.223 [3760] upd: changes [http://help.logmein.com/SelfServiceReleaseNote?product=lmihamachi2]
12/09 14:25:29.233 [3760] upd: package [http://logmeincdn.http.internapcdn.net/logmeincdn/Hamachi_win32_22000279/Hamachi.msi]
12/09 14:25:29.243 [3760] upd: details []
12/09 14:25:29.263 [3088] tap: SetupDiCallClassInstaller() ..
12/09 14:25:29.303 [3760] upd: not updating, have [2.2.0.279], avail [2.2.0.279]
12/09 14:25:29.313 [3760] ses: resolving hamachi-list.3.logmein-gateway.com ..
12/09 14:25:29.384 [3760] ses: selected (h-app03-01.hamachi.cc, 6515)
12/09 14:25:29.444 [3760] ses: selected 01 connection type
12/09 14:25:29.464 [3760] ses: resolving h-app03-01.hamachi.cc ..
12/09 14:25:29.494 [3760] ses: on_ip_change()
12/09 14:25:29.524 [3088] tap: do_status(), rc 1
12/09 14:25:29.544 [3760] ses: on_rt_change()
12/09 14:25:29.604 [3088] tap: device Hamachi re-appeared on the list
12/09 14:25:29.764 [3760] tap: job [Hamachi, JOB_set_tapdev, 1] done, result: success
12/09 14:25:29.864 [3760] vpn: on_set_tapdev(Hamachi, 1) -> ok
12/09 14:25:29.924 [3760] tap: init(), devName [Hamachi]
12/09 14:25:29.944 [3760] tap: list_netdev_win32() ..
12/09 14:25:30.305 [3760] tap: devName Hamachi
12/09 14:25:30.756 [3760] tap: fileName : \\.\HamachiTap.4CBEAC0F-D931-4916-86FC-59AC05B6A39A
12/09 14:25:30.786 [3760] tap: mac : 7a:79:00:00:00:00
12/09 14:25:30.806 [3760] tap: queueSize : 64
12/09 14:25:30.826 [3760] tap: linkSpeed : 100000000
12/09 14:25:30.846 [3760] tap: linkMtu : 1404
12/09 14:25:30.856 [3760] tap: linkState : 1
12/09 14:25:30.876 [3760] tap: vdhcp : 1
12/09 14:25:30.946 [3760] tap: vdhcp.srv : 1.0.254.169
12/09 14:25:30.976 [3760] tap: vdhcp.cli : 0.0.0.0 / 0.0.0.0
12/09 14:25:31.006 [3760] tap: vdhcp.sec : 31536000
12/09 14:25:31.036 [3760] vpn: domain [Hamachi] -> 'VPN_up'
12/09 14:25:31.076 [3760] dbg: setup_vpn_domain [Hamachi]
12/09 14:25:31.126 [3760] dbg: vpn_domain::config - [Hamachi]
12/09 14:25:31.186 [3760] vpn: domain [Hamachi] -> 'VPN_setting_up'
12/09 14:25:31.226 [3760] tap: config(0.0.0.0,0.0.0.0)
12/09 14:25:31.256 [3760] tap: GetAdapterIndexByGuid [{4CBEAC0F-D931-4916-86FC-59AC05B6A39A}]
12/09 14:25:31.266 [3760] tap: adapter 00000002 [\DEVICE\TCPIP_{7A8BEB3C-A02E-45F9-96D5-5FFC8F5774AB}]
12/09 14:25:31.316 [3760] tap: adapter 00020004 [\DEVICE\TCPIP_{4CBEAC0F-D931-4916-86FC-59AC05B6A39A}]
12/09 14:25:31.386 [3760] tap: 0x20004 info 1, 0.0.0.0, 0.0.0.0
12/09 14:25:31.437 [3760] tap: adapter addr 0.0.0.0/0.0.0.0, dhcp yes, want 0.0.0.0/0.0.0.0, [::/0]
12/09 14:25:31.467 [3760] tap: GetAdapterIndexByGuid [{4CBEAC0F-D931-4916-86FC-59AC05B6A39A}]
12/09 14:25:31.497 [3760] tap: adapter 00000002 [\DEVICE\TCPIP_{7A8BEB3C-A02E-45F9-96D5-5FFC8F5774AB}]
12/09 14:25:31.527 [3760] tap: adapter 00020004 [\DEVICE\TCPIP_{4CBEAC0F-D931-4916-86FC-59AC05B6A39A}]
12/09 14:25:31.587 [3760] tap: enabling virtual dhcp server ..
12/09 14:25:31.597 [3760] tap: setDhcp(0, 0.0.0.1, 0.0.0.0/0.0.0.0) = 1, 183
12/09 14:25:31.617 [3760] vpn: tap config done, [ok]
12/09 14:25:31.637 [3760] vpn: domain [Hamachi] -> 'VPN_up'
12/09 14:25:31.677 [3760] ses: connecting to 212.118.234.65:12975 ..
12/09 14:25:31.737 [3760] ses: connection is established
12/09 14:25:31.757 [3760] ses: control connection is bound to 10.183.34.19
12/09 14:25:31.847 [3760] ses: << msg_helo ..
12/09 14:25:31.917 [3760] ses: io error, recv, 10054
12/09 14:25:31.927 [3760] ses: error 3, retryable yes
12/09 14:25:31.937 [3760] ses: go_offline, keep_tunnels 1, login_on_relaunch 0, actual state 10 ..
12/09 14:25:31.967 [3760] ses: reconnect delay: 17 sec
12/09 14:25:49.352 [3760] ses: go_offline, keep_tunnels 1, login_on_relaunch 0, actual state 6 ..
12/09 14:25:49.372 [3760] sys: go_online, reconnect 1
12/09 14:25:49.382 [3760] ses: selected (h-app03-03.hamachi.cc, 6396)
12/09 14:25:49.392 [3760] ses: selected 01 connection type
12/09 14:25:49.412 [3760] ses: resolving h-app03-03.hamachi.cc ..
12/09 14:25:49.442 [3760] ses: connecting to 212.118.234.69:12975 ..
12/09 14:25:49.493 [3760] ses: connection is established
12/09 14:25:49.513 [3760] ses: control connection is bound to 10.183.34.19
12/09 14:25:49.533 [3760] ses: << msg_helo ..
12/09 14:25:49.703 [3760] ses: io error, recv, 10054
12/09 14:25:49.713 [3760] ses: error 3, retryable yes
12/09 14:25:49.723 [3760] ses: go_offline, keep_tunnels 1, login_on_relaunch 0, actual state 10 ..
12/09 14:25:49.753 [3760] ses: reconnect delay: 49 sec
12/09 14:26:05.095 [3760] ipc: new connection
12/09 14:26:05.135 [3760] ipc: connection from [kdrtt]
12/09 14:26:05.145 [3760] ipc: user [kdrtt]
12/09 14:26:05.235 [3760] ipc: 00dfc530 add client 1
12/09 14:26:05.255 [3760] ipc: init() ok
12/09 14:26:38.964 [3760] ses: go_offline, keep_tunnels 1, login_on_relaunch 0, actual state 6 ..
12/09 14:26:39.034 [3760] sys: go_online, reconnect 1
12/09 14:26:39.094 [3760] ses: selected (h-app03-05.hamachi.cc, 6337)
12/09 14:26:39.114 [3760] ses: selected 01 connection type
12/09 14:26:39.144 [3760] ses: resolving h-app03-05.hamachi.cc ..
12/09 14:26:39.264 [3760] ses: connecting to 212.118.234.73:12975 ..
12/09 14:26:39.364 [3760] ses: connection is established
12/09 14:26:39.384 [3760] ses: control connection is bound to 10.183.34.19
12/09 14:26:39.424 [3760] ses: << msg_helo ..
12/09 14:26:39.544 [3760] ses: io error, recv, 10054
12/09 14:26:39.554 [3760] ses: error 3, retryable yes
12/09 14:26:39.575 [3760] ses: go_offline, keep_tunnels 1, login_on_relaunch 0, actual state 10 ..
12/09 14:26:39.725 [3760] ses: reconnect delay: 102 sec
12/09 14:27:46.631 [3760] ses: go_offline, keep_tunnels 0, login_on_relaunch 0, actual state 6 ..

Retired LogMeIn Contributor pz
Retired LogMeIn Contributor

Re: Failed to connect to Hamachi servers

Hi,

 

based on your logs the connection from your Hamachi client to our servers are established, but immediately closed once the first packet is sent.

This suggest the presence of a transparent proxy or firewall.

You need to contact your network administrator.

New Contributor

Re: Failed to connect to Hamachi servers

I HAVE THE SAME PROBLEM! Here are my last 30 lines.

03/06 19:13:44.240 assert cb.erase(_cb) == 1 in ..\client2\ui\ui.cpp:166
03/06 19:13:44.241 ui: term
03/06 19:13:44.241 ntf: clear [0]
03/06 19:13:44.247 cfg: saved()
03/06 19:13:44.251 sta: saved()
03/06 19:13:45.592 ipc: received set_state, 1, 1
03/06 19:13:45.604 ipc: received set_state, 2, 0
03/06 19:13:45.611 ipc: received batch, 1
03/06 19:13:45.611 ipc: received batch, 0
03/06 19:13:45.611 ipc: received set_state, 2, 1
03/06 19:13:45.636 sta: saved()
03/06 19:13:47.019 ipc: sending login, 1
03/06 19:13:47.024 ipc: received set_state, 4, 0
03/06 19:13:47.045 ipc: received set_state, 4, 1
03/06 19:13:47.050 ipc: received set_state, 2, 0
03/06 19:13:47.059 ipc: received batch, 1
03/06 19:13:47.059 ipc: received batch, 0
03/06 19:13:47.060 ipc: received set_state, 2, 1
03/06 19:13:47.064 ipc: received set_state, 8, 0
03/06 19:13:47.649 sta: saved()
03/06 19:13:49.660 sta: saved()
03/06 19:13:59.041 ipc: received set_state, 8, 0
03/06 19:13:59.144 ipc: received set_state, 8, 0
03/06 19:13:59.148 ipc: received set_state, 8, 1
03/06 19:13:59.149 ipc: received set_state, 9, 0
03/06 19:13:59.722 sta: saved()
03/06 19:14:20.153 ipc: received set_state, 8, 0
03/06 19:14:20.156 ipc: received set_state, 8, 1
03/06 19:14:20.158 ipc: received set_state, 9, 0
03/06 19:14:21.861 sta: saved()

 

Any problems with it? Reply as soon as you can! Cat Sad

Retired LogMeIn Contributor

Re: Failed to connect to Hamachi servers

Hi,

 

Could you please send me the h2-engine.log file?

You can find the containing folder path in Hamachi GUI/System/Preferences/Settings/Advanced Settings/Disk Locations/Service configuration.

Thanks,

Istvan

New Contributor

Re: Failed to connect to Hamachi servers

I have recently had problems on multiple machines where Hamachi appears to be working normally but no green dots show next to the other computers on the Hamachi network and the computer with the problem is just not connected to the Hamachi network.  The solution seems to be to take the computer with the problem out of the network and then put it right back in.  

 

This can be done by logging into your account on the Logmein web site, editing the settings for the computer with the connection issue, unchecking the box that shows the network name, clicking apply, then immediately reselecting the same box and clicking apply again.  The computer will immediately connect to the Hamachi network.

New Contributor

Re: Failed to connect to Hamachi servers

make shure you have set in norton to not block the program, it worked for me after i un blocked it.

New Contributor

Re: Failed to connect to Hamachi servers

i dont have service configration file pls help !!