cancel
Showing results for 
Search instead for 
Did you mean: 
boistordu
Active Contributor

hamachi debian 8.2 python error daemon

here is the error when I try to install the daemon :

Traceback (most recent call last):
File "/usr/lib/lsb/remove_initd", line 18, in <module>
headers = initdutils.scan_initfile(initfile)
File "/usr/lib/lsb/initdutils.py", line 79, in scan_initfile
inheaders = RFC822Parser(strob=headerlines)
File "/usr/lib/lsb/initdutils.py", line 24, in __init__
fileob = StringIO(strob)
TypeError: initial_value must be unicode or None, not str
Unpacking logmein-hamachi (2.1.0.139-1) over (2.1.0.139-1) ...
Setting up logmein-hamachi (2.1.0.139-1) ...
mknod: ‘/dev/net/tun’: File exists
Traceback (most recent call last):
File "/usr/lib/lsb/install_initd", line 46, in <module>
headers = initdutils.scan_initfile(initfile)
File "/usr/lib/lsb/initdutils.py", line 79, in scan_initfile
inheaders = RFC822Parser(strob=headerlines)
File "/usr/lib/lsb/initdutils.py", line 24, in __init__
fileob = StringIO(strob)
TypeError: initial_value must be unicode or None, not str

 

 

7 REPLIES 7
RomanS
New Contributor

Re: hamachi debian 8.2 python error daemon

Same here

 

 

Copying files into /opt/logmein-hamachi ..
Creating LogMeIn Hamachi symlink ..
Creating TunTap ..
mknod: ‘/dev/net/tun’: File exists
Installing LogMeIn Hamachi service ..
Traceback (most recent call last):
  File "/usr/lib/lsb/install_initd", line 46, in <module>
    headers = initdutils.scan_initfile(initfile)
  File "/usr/lib/lsb/initdutils.py", line 79, in scan_initfile
    inheaders = RFC822Parser(strob=headerlines)
  File "/usr/lib/lsb/initdutils.py", line 24, in __init__
    fileob = StringIO(strob)
TypeError: initial_value must be unicode or None, not str
Starting LogMeIn Hamachi service ..
Starting LogMeIn Hamachi VPN tunneling engine logmein-hamachi/sbin/start-stop-daemon: unable to start /opt/logmein-hamachi/bin/hamachid (No such file or directory)
 failed!
LogMeIn Hamachi is installed. See README for what to do next.

uname -a

Linux bananapi 3.4.108-bananian #2 SMP PREEMPT Thu Aug 13 06:08:25 UTC 2015 armv7l GNU/Linux
ztefn
Active Contributor

Re: hamachi debian 8.2 python error daemon

As stated on: https://secure.logmein.com/labs/#HamachiforLinux


Please make sure you have the LSB 3.0 (or above) package installed prior to attempt installing the product.

This means that on Debian you need the package lsb-core. If you had used the .deb package instead of .tar.gz this dependency would have been resolved automatically.

odroid_xu4
New Contributor

Re: hamachi debian 8.2 python error daemon

Hi Everyone, 

 

I have the same issue, but I've installed prior lsb and lsb-core. I get the same error:

 

unable to start /opt/logmein-hamachi/bin/hamachid (No such file or directory)

 

uname-a

 

Linux odroid 3.10.92. #1 SMP PREEMPT Tue Nov 17 00:15:24 BRST 2015 armv71 armv71 armv71 GNU/Linux

exalented
New Contributor

Re: hamachi debian 8.2 python error daemon

ive done:

 

wget logmein-hamachi_2.1.0.139-1_armhf.deb

apt-get install lsb-core

dpkg -i logmein-hamachi_2.1.0.139-1_armhf.deb

 

*repeat because it doesn't work*

I purge it and start again......

 

I've been having this issue and im fed-up with it. I'm using kali linux 2.0 for raspberry pi 2 on my model B AND ITS NOT WORKING AHHH!

 

Can anyone help me or do i have to install a new OS?

gadget20
New Contributor

Re: hamachi debian 8.2 python error daemon

Same issue here:

 

I have raspberry pi 1 B+

already tried using the latest raspbian jessie and jessie lite and I always get the same issue.

 

2016-03-18-raspbian-jessie-lite.deb
2016-03-18-raspbian-jessie.deb

hamachi version I already tried are

 

logmein-hamachi_2.1.0.139-1_armhf.deb
logmein-hamachi_2.1.0.139-1_armel.deb

lsb and lsb-core installed before installing hamachi still same issue.

 

The way I installed hamachi

#wget <hamachi version here>
#apt-get update
#apt-get install lsb lsb-core -y
#dpkg -i <hamachi version here>
#hamachi login
#hamachi attach <my email address here>
#hamachi set-nick rpi1bplus

go to logmein hamachi website
https://secure.logmein.com/central/central.aspx

Under My Network, approve the pending
then join it to your existing network if you have

 

The issue is... I can install hamachi... at the very end this is what I get after installing

Setting up lsb-core (4.1+Debian13+rpi1+nmu1) ...
ld-lsb-*.so.1 symlink for armhf is unknown!
Setting up logmein-hamachi (2.1.0.139-1) ...
Traceback (most recent call last):
  File "/usr/lib/lsb/install_initd", line 46, in <module>
    headers = initdutils.scan_initfile(initfile)
  File "/usr/lib/lsb/initdutils.py", line 79, in scan_initfile
    inheaders = RFC822Parser(strob=headerlines)
  File "/usr/lib/lsb/initdutils.py", line 24, in __init__
    fileob = StringIO(strob)
TypeError: initial_value must be unicode or None, not str

Hamachi is running if I will check with

ps -ef | grep hamachi

 

And I can verify in the website of logmein that my raspberry pi is up and acquired an IP address and it is GREEN

 

But when I try to access my from the same network of hamachi vpn, pi is not pingable and accessible.

 

When I checked PI, I verified hamachi is running but there are no added routes and there is no interface for hamachi... there is no TUN interface for the IP I acquired and I am not able to ping my other devices that are online and in the same hamachi network.

 

this is so frustrating.... I was able to make this work before using wheezy using same approach.

 

 

Anyone got a solution?

palermojammer
New Contributor

Re: hamachi debian 8.2 python error daemon

Hi there,

 

anybody got a solution to this, since i got the same issue?

 

Thx

tadeu00
New Contributor

Re: hamachi debian 8.2 python error daemon

Only solution I found was to do this command.

apt --fix-broken install

This command successfully installed lsb-core. Then I managed to install Hamachi.