Showing results for 
Search instead for 
Did you mean: 
New Contributor


Gracias por la ayuda Anon309484. Lamentablemente he seguido todos los pasos que describes en tu post y no he sido capaz de desinstalar Logmein Hamachi en su versión


Llevo varios días dandole vueltas y probando de todos los modos posibles, pero nada, imposible. La verdad es que es frustrante. En mi caso la idea era desinstalar la anterior versión para poder instalar un nueva pero me da la impresión que al encontrar la antigua versión no me deja instalar la nueva.


En fin si encuentro algo os lo hago saber.



New Contributor


I got it!


After wasting a lot of hours trying to uninstall version of LogMeIn Hamachi2, I found the solution!


First, I have to say my first attempt was to update my versión of Hamachi, but I got stuck with the message "Another version of this product is already installed". Then I tried all the staff found in this post "MANUAL UNINSTALL" -> No Way Jose.  I realized the Hamachi Network Interface was still on my device list and I was unable to get rid of it. I found a procedure to remove network adapters here:


Then I went to install the latest version of LogMeIn Hamachi2 and, very important, uncheck the option "Want to keep the older configuration".


After all this, VPN Hamachi worked.


I have not tried to uninstall again. I hope I have no need to do so in the next 10 years. 
















New Contributor


LogMeIn does do as advertised -- it will allow people to remotely connect for IT support, etc.  However, the fact that none of LMI's techs have bothered to comment in this thread for three years is a huge clue to the quality of their customer follow-through.  It appears to be a you-don't-pay-we-don't-care type of deal.  They just let their free users solve things for themselves.

Personally, I will never install this invasive, junk software on my computer again.  Nearly 300 entries had to be deleted -- and this was after I uninstalled the program properly with their own uninstaller!

I finally completely removed every discernable trace of this junkware.  Here's how I removed it on XP Pro: 



The following assumes that you are an advanced user who is experienced with the dangers of registry editing and service handling.  Always backup your files and your registry before making any changes.


I started with the guidance from this page.  It's dated, but it's a good start.

1.  Uninstall LogMeIn using the normal Add/Remove Programs option.

2.  Get ProcessHacker from SourceForge.  (Open source, freeware.)

3.  Unzip (or install, depending on which file you downloaded), then run.

4.  Using ProcessHacker under the Processes tab, stop all LogMeIn processes, if any.

5.  Now go to the Services tab.  Sort by "Name" by clicking the "Name" column title.

6.  Examine the properties of any that start with LMI (LMIinfo, LMImirr, LMIRfsClientNP, LMIRfsDriver, etc.) by right-clicking and choosing "Properties".

7.  You can then find out where the file is located.  Navigate to the indicated folder, then make sure it is a "logmein" file by right-clicking and examining its properties.

8.  Once you have a target logmein file, return to the ProcessHacker Services list.  Then you can right-click and stop/delete the service.  (ProcessHacker will notify you that the services that can't be stopped will be deleted.  They will disappear on the next reboot.)

9.  Close ProcessHacker and search your system drive for files named LMI*.*  .  Check the properties of the files to make sure they are from "logmein, inc". 

10. Delete what you can.  Some are protected.  Those can be removed by steps below.


Careful here to delete only the LogMeIn keys and values!

11. Go to Start/Run and type regedit.  Then follow the instructions below. Make sure you read each of the values carefully to avoid problems:


HKEY_CURRENT_USER -> Software -> LogMeIn

HKEY_LOCAL_MACHINE -> Software -> Microsoft -> Cryptography -> Services -> LogMeIn


HKEY_LOCAL_MACHINE -> System -> CurrentControlSet -> Control -> NetworkProvider -> HwOrder -> ProviderOrder and remove the LMIRfsClientNP from the list.

HKEY_LOCAL_MACHINE -> System -> CurrentControlSet -> Control -> NetworkProvider -> Order -> ProviderOrder and remove the LMIRfsClientNP from the list.


12.  Close regedit.  Now do another search for LMI*.* on your system drive.  Rename the files that couldn't be deleted earlier. Reboot.

13.  After rebooting, the files you renamed should now be able to be removed.


For those who, like me, insist on insane cleanliness:

14. Get "RegScanner" from Nirsoft and search for LogMeIn values to remove.  This isn't necessary and is not advised for beginner-intermediate skill levels.


15.  Avoid LMI until they clean up the trash that their uninstaller leaves behind!


Joe Bones



New Contributor


I've followed it exactly, and now it says 'Service 'LogMeIn Hamachi Tunneling Engine' (Hamachi2Svc) could not be installed. Verify that you have sufficient priveleges to install system services.'
I know in the past I blocked it on a bullguard antivirus, but I've unblocked it and it still says the same thing. What can I do? 

New Contributor


Where do I begin.  Let's just start at the top and work our way down.


First, my technical issue - I used Group Policy to deploy LMI, but it would not uninstall properly once the computer fell out of the scope of management.  I know it is not uninstalling properly because when I run gpresult /H gpreport.htm after the uninstall and reboot, it always notes a pending installation.  This is a problem because now whenver I do a gpupdate (no matter how many reboots have been done), it's going to require to reboot the computer to complete the gpupdate.  Unacceptable.


@Anon46330 - Your method seems thorough, but it is not thorough enough.


@KGHalbe - "First of all, thanks for doing a search and a bit of research for yourselfblah blah blah..."  It amazes me that a patronizing, sinnacle attitude like that earned you a "VIP" title on these forums.  How about you, your high horse and your self-righteousness take a nice long stroll somewhere else and stop belittling people here.  Good grief.


@JoeBones - Excellent writeup on your method!


Here's my solution:


Something I noticed is that once I deployed LMI via Group Policy, it did not appear in Add/Remove Programs.  However, it DOES appear in RevoUninstaller.


So, download RevoUninstaller Free at and install it.  Once you have Revo open, double-click the LogMeIn icon to begin the process.  Revo will create a System Restore point, then begin the uninstaller.  If you're in my situation, the LMI uninstaller will stop with a message about "Another version of this product is already installed, etc etc".  Go ahead and close that.  Next, Revo will scan the registry and disk for leftover files and folders.  For each of those screens, click "Select All" and then click "Delete".  Finish.


Some of my terminology for the uninstall process aren't exactly verbatim, but it's pretty intuitive and self-explanitory.


Result for me:  I'm no longer required to reboot a computer just because I did a gpupdate.  Also, the gpresult report no longer denotes "another installation" either.  Hooray!  Unfortunately, this means I won't be using Group Policy to deploy LMI.  We cannot afford the added time that will be needed when we do a gpupdate on a workstation to reboot it just because Group Policy deployments of LMI are clearly broken.

New Contributor


Sadly, we have found the same thing.  Installs group via GPO/push install or scripted install ... however uninstalling, well that's pretty reliably incomplete and will break an installation of trying to update/remove via Group Policy.


Hopefully this gets addressed because it's a great tool.

New Contributor


i had this problem before and my solution was as follows:


i followed what Anon46330 said on deleting the Registry Key only then after that i ran another Installation, like i was installing on top, then i chose UNINSTALL option.


REF: Anon46330 (You can do this by going to the Start menu and selecting Run. Type regedit and press okay. Click: 

the + next to HKEY_LOCALMACHINE 
the + next to SOFTWARE 
the + next to CLASSES 
the + next to INSTALLER 
the + next to PRODUCTS 

Next, please click on each folder, until you find the one on the right that says Product Name = Remotely Anywhere or Logmein. Delete this key and then attempt to re-install the software.)



New Contributor


Once again it gets pointed out that people are not using the forum properly.  Reposting articles getting in trouble for it. It also says open a command line.  okay standard statement to run a command line is type "cmd" or open command prompt.  


FAIL.  The added instruction run command line as administrator even if the person logged in is an administrator they do not contain enough authorization to run a Administrator Command Line. 


So if ANYONE is going to include instructions directions to knowledge based articles etc.  INCLUDE full instructions.. Stop arguing with people who actually contribute information.  Those elite users Get off your HIGH HORSE and stop being so rude.  If you are an elite user and post a rude response then you have now lowered to unprofessionalism.  

New Contributor



Your manual is usefull 🙂

New Contributor


Anon46330 - Thank you! This worked perfectly. Why it has to be so difficult to uninstall LMI is beyond me. The software is excellent for remote access but an otherwise great experience is ruined by this issue. Hire some decent code writers and get this fixed, LMI.