cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Failed connecting to engine?

Okay im running windows 7, and installed hamachi, and it has worked fine, but now it comes with the error failed connecting to engine.

Ive reinstalled, and seached google for a hour or more, i cant get it to work!

Please Help!

10 REPLIES
New Contributor

Re: Failed connecting to engine?

Have you tried the Hamachi online help?  Generally you need to try restarting the LogMeIn Hamachi 2.0 Tunneling Engine service, or if the service isn't present you may need to modify your Registry.  

For detailed instructions, navigate to the LogMeIn Hamachi support, enter "engine" into the knowledge base search field.

 

Regards,

 

New Contributor

Re: Failed connecting to engine?

I was having the same problem since moving to WIN 7.  The solution on my computer was to gain access to the service configuration folder.  On my computer it is:

 

C:\Windows\system32\config\systemprofile\AppData\Local\LogMeIn Hamachi

 

Using explorer, I had to confirm that I wanted access to that folder.  Been working OK now.

New Contributor

Re: Failed connecting to engine?

I was encountering this error after trying to tweak my XP startup using Soluto.

 

I found this link and information effective in starting and making sure the Hamachi tunnel engine was running before starting Hamachi:


http://gainesvillecsi.blogspot.com/2010/08/hamachi-failed-to-connect-to-engine.html

 

Involves simply doing this:

 

The fix is to start services.msc, navigate to LogMeIn Hamachi 2.0 Tunneling Engine, start the tunnel, then start Hamachi.

 

Worked for me, maybe it will help others....

New Contributor

Re: Failed connecting to engine?

Is there a way of "automating" this task when it can't connect?

New Contributor

Re: Failed connecting to engine?

This happened to me too... What you do is press the windown/start button on your keyboard and the R button (http://mwe.malwareexperts.netdna-cdn.com/wp-content/uploads/2011/12/windows-key-r-key-keyboard.png) at same time. This should pull up something called "Run". Type "services.msc" in the box and the click ok. This should pull up something called "Services". Scroll down until you see "Logmein Hamachi", click it, then click "Start the service". This should then pull up Hamachi. If that doesn't work then press Ctrl (Control), Shift, and Esc (Escape) at the same time (http://www.napatec.com/Ctrl-Shift-Esc.png). Scroll down until you see "hamachi-2-ui.exe" Click it, then click End Process. Restart computer after this then try to open Logmein Hamachi.

 

 

~Zackpip

New Contributor

Re: Failed connecting to engine?

I am having the same problem yet when I pull up services.msc and I look for LogMeIn Hamachi Tunneling Engine it doesn't let me start, stop, or do anything to it. All the choices are locked

 

Frequent Contributor

Re: Failed connecting to engine?

if you are using vista-7, disable UAC on pc, reboot. not uninstall hamachi, reboot, and install it again. after reboot it should work with no issiue.

 

 

 

regards

 

szametu

 

 

http://myvpnworld.wordpress.com/

New Contributor

Re: Failed connecting to engine?

Yes this is the service issue. all you need to do is to start the service: LogMeIn Hamachi Tunneling Engine

that'll solve the problem.

New Contributor

Re: Failed connecting to engine?