cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor

change hamachi ip

Hi,

 

Here is the problem: I have two identical machines. I've installed hamachi in one of them (ubuntu 11.04) and after I cloned the whole disk into the second machine. Even though the names of the two machines is different, also in my hamachi network (set-nick), they both have the same IP. The problem is that when both machines are connected simultaneously the network kicks one out.. I tried "leaving" the network, editing on the web page, but when I join again it comes back with the same IP. How do I change the client configuration file so that conflict would not occur?

 

Thanks,

 

Daniel

1 ACCEPTED SOLUTION

Accepted Solutions
Retired LogMeIn Contributor

Re: change hamachi ip

Hello danielsender,

 

Thanks for the question, and welcome to the community. The reason both computers have the same IP address is because when you cloned the hard drive, you copied the service configuration folder for Hamachi. Because of this, the gateway server sees both machines as the same, hence why only one can be logged in at a time. To fix this, you will need to delete one of the service configuration folders. The file are normally stored in /var/lib/logmein-hamachi, so to reset this folder would require the following commands 

 

 

sudo /etc/init.d/logmein-hamachi stop

 This stops the Hamachi daemon, allowing you to delete the folder contents

 

sudo rm /var/lib/logmein-hamachi/*

 This removes all files in the service configuration directory

 

sudo /etc/init.d/logmein-hamachi start

 This restarts the Hamachi daemon, which will automatically create a new relationship with the Hamachi gateway server, repopulating the service configuration directory

 

I hope this helps, but if you still are having trouble, our support department may be able to help with any further issues you may have.

 

https://secure.logmein.com/contactus

 

Regards,

Kevin Watson
Technical Support Representative
LogMeIn, Inc.
Email: kwatson@logmein.com
7 REPLIES
Retired LogMeIn Contributor

Re: change hamachi ip

Hello danielsender,

 

Thanks for the question, and welcome to the community. The reason both computers have the same IP address is because when you cloned the hard drive, you copied the service configuration folder for Hamachi. Because of this, the gateway server sees both machines as the same, hence why only one can be logged in at a time. To fix this, you will need to delete one of the service configuration folders. The file are normally stored in /var/lib/logmein-hamachi, so to reset this folder would require the following commands 

 

 

sudo /etc/init.d/logmein-hamachi stop

 This stops the Hamachi daemon, allowing you to delete the folder contents

 

sudo rm /var/lib/logmein-hamachi/*

 This removes all files in the service configuration directory

 

sudo /etc/init.d/logmein-hamachi start

 This restarts the Hamachi daemon, which will automatically create a new relationship with the Hamachi gateway server, repopulating the service configuration directory

 

I hope this helps, but if you still are having trouble, our support department may be able to help with any further issues you may have.

 

https://secure.logmein.com/contactus

 

Regards,

Kevin Watson
Technical Support Representative
LogMeIn, Inc.
Email: kwatson@logmein.com
New Contributor

Re: change hamachi ip

Hi Kevin,

 

It worked great! As I said in my posting since I cloned the disk (dual boot XP and Ubuntu) I have the same issue on the XP side, so how do I change the hamachi  configuration files?

 

Many thanks!

 

Daniel

New Contributor

Re: change hamachi ip

What is the solution for the sameproblem on a Windows machine?

New Contributor

Re: change hamachi ip

i want to know that to im using windows vista if it helps

Retired LogMeIn Contributor pz
Retired LogMeIn Contributor

Re: change hamachi ip

No matter what windows version(XP, 7) you use:

- go to System|Preferences|Advanced Settings|Disk Locations|Service Configuration

- stop the LogMeIn Hamachi Tunneling Engine in Services

- delete the contents of the service configuration folder

- start the service

 

or you may just want to uninstall with "Remove all user settings" checked and reinstall.

 

New Contributor

Re: change hamachi ip

hello, i really need some help here.. the folder /var/lib/logmein-hamachi makes no sense to me. How do you get there? how do you tell it a command?

 

i just really need help. i recently got a new router/modem and my ip address changed. now i cant host anything because hamachi still recognizes my old ip address but my games recognize the new one. HOW DO I CHANGE THIS????

Active Contributor

Re: change hamachi ip

try:

C:\Windows\ServiceProfiles\LocalService\AppData\Local\LogMeIn Hamachi