cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Re: Failed to connect to the engine

I'm fed up by the unreliability of Logmein and Hamachi.  I've been fighting issues with Hamachi for years where random computers would stop connecting to Hamachi, requiring truck rolls to dispatch a tech to connect a monitor and manually start the Hamachi service.  I've probably seen three cases this year where clients suddenly stopped being attached to my email account, so they disappear from Central altogether, requiring a truck roll.

 

When I contacted Logmein support to complain about high "Failed to connect to the engine' failures last year, I was not provided any solution and only suggested that I also install Logmein Free so that if Hamachi fails, I can login with Logmein and re-enable Hamachi.

 

This did use up more resources on these machines but it did save nearly all Hamachi failures from having to do a truck roll. However, Logmein Free dropped to 10 PC's, and so I cannot use Logmein to connect to these failed Hamachi clients anymore.  I can still see Logmein online status in my account, so I can sometimes tell if hamachi failed again and PC is actually online.

 

I've had to resort to installing Neorouter on all these machines.  I am finding that many machines that report Logmein and Hamachi are actually still online and working with Neorouter!  In the last 1-2 months, both Logmein and Hamachi have experienced very high failure counts.  Rather than it being 1-2 a month, its several more.  I'm guessing that something got updated recently that was poorly coded and stopping the service or something.  Each time, manually starting the service from services.msc reconnected to Hamachi.

 

I am very surprised that Logmein Hamachi doesn't do the most basic recovery attempt in restarting the service and starting up.  This is a product intended for remote, unattended access and there is very little attention or care to ensuring that the service gets (re)started in the event of a failure.

 

I have paid services for several more months, but if this problem doesn't improve by then, I can't see myself renewing again.

New Contributor

Re: Failed to connect to the engine

I have done all this and it still won't start for me. It keeps telling me...

 

*Failed to Connect to Engine.*

 

Then it will tell me...

 

*Windows could not start the LogMeIn Hamachi Tunneling Engine service on Local Computer.*

 

*Error 1053: The service did not respond to the start or control request in a timely fashion.*

 

It was working for me the other day and now it won't start at all. Please help me since I know LogMeIn will not... :'(

New Contributor

Re: Failed to connect to the engine

I have the error 1053 too.

New Contributor

Re: Failed to connect to the engine

Hey! I have done everything that has been said here and none have worked... except for one of the solutions here:
 http://help.logmein.com/selfserviceknowledgerenderer?type=FAQ&id=kA030000000DGCxCAO

I was getting the error 1053 when using the services.msc solution, but then i tried the registry one.
When i tried to start the Tunneling Engine again no error 1053!

What i did was:
-Follow the instructions in the link above (to open the registry editor you windows key+r, then type in regedit).

-Create the "EngineConfigDir" as instructions say.

-Right click the newly created EngineConfigDir > Modify (as instructions DONT say) , then on data you type in any folder adress (i just copied the "InstallDir").

-Start the "LogMeIn Hamachi Tunneling Engine"

-Open Hamachi like you would normally


New Contributor

Re: Failed to connect to the engine

Hi folks,

After trying and searching for almost 2 hours!, I have read Trixker's post, took a look at the link mentioned in his post, and following that instructions, Hamachi worked like a champ!!! (at least here, on my Windows 8 Pro 64-bit notebook).

This is the FAQ:

http://help.logmein.com/selfserviceknowledgerenderer?type=FAQ&id=kA030000000DGCxCAO

 

I also have tried some other tips on other posts, but weren't working. When I found this post (Trixker), I followed the steps mentioned on the article, then I was finally able to start the LogMeIn Hamachi Tunneling Service ("net start hamachi2svc" from the Command Prompt).

In my case, I have set the path "C:\Windows\ServiceProfiles\LocalService\AppData\Local\LogMeIn Hamachi" in the EngineConfigDir string value, but as the article says, I think you can choose the path you want.

 

Anyway, I think LogMeIn could prevent this issue to happen, I don't know how difficult that could be for the developers to fix, but I guess they can do it. I hope they fix that.

 

Thank you Trix!!! I thank you a lot! Smiley Happy

(sorry for my english, trying to improve :-) )

 

Hope you all have success!

Best regards,

Alexandre

New Contributor

Re: Failed to connect to the engine

Here, I just Made a Video about that problem  Smiley Very Happy!

 

 

https://www.youtube.com/watch?v=KChMcZUyau4&feature=youtu.be

New Contributor

Re: Failed to connect to the engine

do you know how to fix it for mac?
New Contributor

Re: Failed to connect to the engine

after I solve 1068 I got 1053
New Contributor

Re: Failed to connect to the engine

 
Highlighted
New Contributor

Re: Failed to connect to the engine

We were having the same "failed to connect to engine" issue on mac os el cap / sierra.

 

Our solution was:

  1. open system preferences > users & groups > login items
  2. Logmein hamachi showed a yellow yeild sign and "unknown"
  3. select logmein hamachi and press the "-" below to remove from startup items.
  4. restart computer. hamachi opens and connects fine.

hopefully this helps others as well.